[Full-disclosure] FLEA-2007-0009-1: xorg-x11 freetype



Foresight Linux Essential Advisory: 2007-0009-1
Published: 2007-04-05

Rating: Major

Updated Versions:
xorg-server=/foresight.rpath.org@fl:1-devel//1/1.2.0-3-1
libX11=/foresight.rpath.org@fl:1-devel//1/1.1.1-2
libXfont=/foresight.rpath.org@fl:1-devel//1/1.2.8-2

freetype=/conary.rpath.com@rpl:devel//1//foresight.rpath.org@fl:1-devel//1/2.3.3-0.0.1-1
group-dist=/foresight.rpath.org@fl:1-devel//1/1.1-0.13-2

References:
http://issues.foresightlinux.org/browse/FL-223
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1003
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1351
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1352
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1667

Description:
Previous versions of the freetype and xorg-x11 packages are vulnerable to
several attacks in which a program run by an authenticated user can easily crash
the X server (Denial of Service) and possibly also cause the X server to execute
arbitrary malicious code as the root user.

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/