[Full-disclosure] MDKSA-2005:222 - Updated mailman packages fix various vulnerabilities



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2005:222
http://www.mandriva.com/security/
_______________________________________________________________________

Package : mailman
Date : December 2, 2005
Affected: 10.1, 10.2, 2006.0, Corporate 3.0
_______________________________________________________________________

Problem Description:

Scrubber.py in Mailman 2.1.4 - 2.1.6 does not properly handle UTF8
character encodings in filenames of e-mail attachments, which allows
remote attackers to cause a denial of service. (CVE-2005-3573)

In addition, these versions of mailman have an issue where the server
will fail with an Overflow on bad date data in a processed message.

The version of mailman in Corporate Server 2.1 does not contain the
above vulnerable code.

Updated packages are patched to correct these issues.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3573
_______________________________________________________________________

Updated Packages:

Mandriva Linux 10.1:
b62f2bdad4a9295bcedec597f5479843 10.1/RPMS/mailman-2.1.5-7.5.101mdk.i586.rpm
4ebd694b50ccbc9f2b602676840c4bc9 10.1/SRPMS/mailman-2.1.5-7.5.101mdk.src.rpm

Mandriva Linux 10.1/X86_64:
a887edf3dd65a418c441fae7588f7e5e x86_64/10.1/RPMS/mailman-2.1.5-7.5.101mdk.x86_64.rpm
4ebd694b50ccbc9f2b602676840c4bc9 x86_64/10.1/SRPMS/mailman-2.1.5-7.5.101mdk.src.rpm

Mandriva Linux 10.2:
99e3dbde709dfa5eb7bd71041adf41be 10.2/RPMS/mailman-2.1.5-15.2.102mdk.i586.rpm
c01867687ff9c78b4c1e2da9d70c4f11 10.2/SRPMS/mailman-2.1.5-15.2.102mdk.src.rpm

Mandriva Linux 10.2/X86_64:
c66dd1916ba0d8ecf8796b1890a064fd x86_64/10.2/RPMS/mailman-2.1.5-15.2.102mdk.x86_64.rpm
c01867687ff9c78b4c1e2da9d70c4f11 x86_64/10.2/SRPMS/mailman-2.1.5-15.2.102mdk.src.rpm

Mandriva Linux 2006.0:
f917270b5334f62843bbdb4a06d12ae0 2006.0/RPMS/mailman-2.1.6-6.2.20060mdk.i586.rpm
15bc0be9373657ac39a9e3956de90801 2006.0/SRPMS/mailman-2.1.6-6.2.20060mdk.src.rpm

Mandriva Linux 2006.0/X86_64:
e92b1dd1ae0bfe3bbc61ba5d6f3b52c3 x86_64/2006.0/RPMS/mailman-2.1.6-6.2.20060mdk.x86_64.rpm
15bc0be9373657ac39a9e3956de90801 x86_64/2006.0/SRPMS/mailman-2.1.6-6.2.20060mdk.src.rpm

Corporate 3.0:
867bdc1fe018e94eb4d5352fc69747ae corporate/3.0/RPMS/mailman-2.1.4-2.5.C30mdk.i586.rpm
572477eb207dadbabc22b0e53b0c2b2b corporate/3.0/SRPMS/mailman-2.1.4-2.5.C30mdk.src.rpm

Corporate 3.0/X86_64:
8a4cc67f45481e9d4b25c41e80f54809 x86_64/corporate/3.0/RPMS/mailman-2.1.4-2.5.C30mdk.x86_64.rpm
572477eb207dadbabc22b0e53b0c2b2b x86_64/corporate/3.0/SRPMS/mailman-2.1.4-2.5.C30mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFDkKPamqjQ0CJFipgRAli4AKCLkrxtdpNyvYclD5KxuVVAZFAHCgCgw0NO
Uq5wc0mG0ABsi0Kyn7l6xR0=
=e/3r
-----END PGP SIGNATURE-----
_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/



Relevant Pages

  • [Full-disclosure] [ MDVSA-2010:079 ] irssi
    ... Multiple vulnerabilities has been found and corrected in irssi: ... The updated packages have been patched to correct these issues. ... Mandriva Linux 2009.1/X86_64: ... GPG public key of the Mandriva Security Team by executing: ...
    (Full-Disclosure)
  • [Full-disclosure] [ MDVSA-2010:079 ] irssi
    ... Multiple vulnerabilities has been found and corrected in irssi: ... The updated packages have been patched to correct these issues. ... Mandriva Linux 2009.1/X86_64: ... GPG public key of the Mandriva Security Team by executing: ...
    (Full-Disclosure)
  • [Full-disclosure] [ MDVSA-2010:245 ] krb5
    ... A vulnerability was discovered and corrected in krb5: ... Packages for 2009.0 are provided as of the Extended Maintenance ... Mandriva Linux 2009.0/X86_64: ... GPG public key of the Mandriva Security Team by executing: ...
    (Full-Disclosure)
  • [ MDVSA-2010:079 ] irssi
    ... Multiple vulnerabilities has been found and corrected in irssi: ... The updated packages have been patched to correct these issues. ... Mandriva Linux 2009.1/X86_64: ... GPG public key of the Mandriva Security Team by executing: ...
    (Bugtraq)
  • [ MDVSA-2010:245 ] krb5
    ... A vulnerability was discovered and corrected in krb5: ... Packages for 2009.0 are provided as of the Extended Maintenance ... Mandriva Linux 2009.0/X86_64: ... GPG public key of the Mandriva Security Team by executing: ...
    (Bugtraq)