[Full-disclosure] [ GLSA 200508-01 ] Compress::Zlib: Buffer overflow

From: Sune Kloppenborg Jeppesen (jaervosz_at_gentoo.org)
Date: 08/01/05

  • Next message: Reed Arvin: "[Full-disclosure] Buffer overflow in BusinessMail email server system 4.60.00"
    To: gentoo-announce@gentoo.org
    Date: Mon, 1 Aug 2005 07:57:55 +0200
    
    
    
    

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory GLSA 200508-01
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

      Severity: High
         Title: Compress::Zlib: Buffer overflow
          Date: August 01, 2005
          Bugs: #100540
            ID: 200508-01

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Synopsis
    ========

    Compress::Zlib is vulnerable to a buffer overflow which could
    potentially lead to execution of arbitrary code.

    Background
    ==========

    The Compress::Zlib is a Perl module which provides an interface to the
    zlib compression library.

    Affected packages
    =================

        -------------------------------------------------------------------
         Package / Vulnerable / Unaffected
        -------------------------------------------------------------------
      1 dev-perl/Compress-Zlib < 1.35 >= 1.35

    Description
    ===========

    Compress::Zlib 1.34 contains a local vulnerable version of zlib, which
    may lead to a buffer overflow.

    Impact
    ======

    By creating a specially crafted compressed data stream, attackers can
    overwrite data structures for applications that use Compress::Zlib,
    resulting in a Denial of Service and potentially arbitrary code
    execution.

    Workaround
    ==========

    There is no known workaround at this time.

    Resolution
    ==========

    All Compress::Zlib users should upgrade to the latest version:

        # emerge --sync
        # emerge --ask --oneshot --verbose ">=dev-perl/Compress-Zlib-1.35"

    References
    ==========

      [ 1 ] GLSA 200507-19
            http://www.gentoo.org/security/en/glsa/glsa-200507-19.xml
      [ 2 ] GLSA 200507-05
            http://www.gentoo.org/security/en/glsa/glsa-200507-05.xml
      [ 3 ] CAN-2005-1849
            http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-1849
      [ 4 ] CAN-2005-2096
            http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-2096

    Availability
    ============

    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:

      http://security.gentoo.org/glsa/glsa-200508-01.xml

    Concerns?
    =========

    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users machines is of utmost
    importance to us. Any security concerns should be addressed to
    security@gentoo.org or alternatively, you may file a bug at
    http://bugs.gentoo.org.

    License
    =======

    Copyright 2005 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).

    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.

    http://creativecommons.org/licenses/by-sa/2.0

    
    

    
    

    _______________________________________________
    Full-Disclosure - We believe in it.
    Charter: http://lists.grok.org.uk/full-disclosure-charter.html
    Hosted and sponsored by Secunia - http://secunia.com/



  • Next message: Reed Arvin: "[Full-disclosure] Buffer overflow in BusinessMail email server system 4.60.00"

    Relevant Pages