[Full-disclosure] [ GLSA 200504-27 ] xine-lib: Two heap overflow vulnerabilities

From: Thierry Carrez (koon_at_gentoo.org)
Date: 04/26/05

  • Next message: Paul Schmehl: "Re: [Full-disclosure] (no subject)"
    Date: Tue, 26 Apr 2005 22:48:08 +0200
    To: gentoo-announce@lists.gentoo.org
    
    
    
    

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory GLSA 200504-27
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

      Severity: Normal
         Title: xine-lib: Two heap overflow vulnerabilities
          Date: April 26, 2005
          Bugs: #89976
            ID: 200504-27

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Synopsis
    ========

    Two vulnerabilities have been found in xine-lib which could lead to the
    remote execution of arbitrary code.

    Background
    ==========

    xine-lib is a multimedia library which can be utilized to create
    multimedia frontends.

    Affected packages
    =================

        -------------------------------------------------------------------
         Package / Vulnerable / Unaffected
        -------------------------------------------------------------------
      1 media-libs/xine-lib < 1.0-r2 >= 1.0-r2
                                                              *>= 1_rc6-r2

    Description
    ===========

    Heap overflows have been found in the code handling RealMedia RTSP and
    Microsoft Media Services streams over TCP (MMST).

    Impact
    ======

    By setting up a malicious server and enticing a user to use its
    streaming data, a remote attacker could possibly execute arbitrary code
    on the client computer with the permissions of the user running any
    multimedia frontend making use of the xine-lib library.

    Workaround
    ==========

    There is no known workaround at this time.

    Resolution
    ==========

    All xine-lib users should upgrade to the latest version:

        # emerge --sync
        # emerge --ask --oneshot --verbose media-libs/xine-lib

    References
    ==========

      [ 1 ] Xine Advisory XSA-2004-8
            http://xinehq.de/index.php/security/XSA-2004-8

    Availability
    ============

    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:

      http://security.gentoo.org/glsa/glsa-200504-27.xml

    Concerns?
    =========

    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users machines is of utmost
    importance to us. Any security concerns should be addressed to
    security@gentoo.org or alternatively, you may file a bug at
    http://bugs.gentoo.org.

    License
    =======

    Copyright 2005 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).

    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.

    http://creativecommons.org/licenses/by-sa/2.0

    
    

    
    

    _______________________________________________
    Full-Disclosure - We believe in it.
    Charter: http://lists.grok.org.uk/full-disclosure-charter.html
    Hosted and sponsored by Secunia - http://secunia.com/



  • Next message: Paul Schmehl: "Re: [Full-disclosure] (no subject)"