[Full-disclosure] [ GLSA 200504-10 ] Gld: Remote execution of arbitrary code

From: Sune Kloppenborg Jeppesen (jaervosz_at_gentoo.org)
Date: 04/13/05

  • Next message: Sune Kloppenborg Jeppesen: "[Full-disclosure] [gentoo-announce] [ GLSA 200504-10 ] Gld: Remote execution of arbitrary code"
    To: gentoo-announce@gentoo.org
    Date: Wed, 13 Apr 2005 14:08:19 +0200
    
    
    
    

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory GLSA 200504-10
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

      Severity: High
         Title: Gld: Remote execution of arbitrary code
          Date: April 13, 2005
          Bugs: #88904
            ID: 200504-10

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Synopsis
    ========

    Gld contains several serious vulnerabilities, potentially resulting in
    the execution of arbitrary code as the root user.

    Background
    ==========

    Gld is a standalone greylisting server for Postfix.

    Affected packages
    =================

        -------------------------------------------------------------------
         Package / Vulnerable / Unaffected
        -------------------------------------------------------------------
      1 mail-filter/gld <= 1.4 >= 1.5

    Description
    ===========

    dong-hun discovered several buffer overflows in server.c, as well as
    several format string vulnerabilities in cnf.c.

    Impact
    ======

    An attacker could exploit this vulnerability to execute arbitrary code
    with the permissions of the user running Gld, the default user being
    root.

    Workaround
    ==========

    There is no known workaround at this time.

    Resolution
    ==========

    All Gld users should upgrade to the latest version:

        # emerge --sync
        # emerge --ask --oneshot --verbose ">=mail-filter/gld-1.5"

    References
    ==========

      [ 1 ] SecurityTracker ID 1013678
            http://securitytracker.com/alerts/2005/Apr/1013678.html

    Availability
    ============

    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:

      http://security.gentoo.org/glsa/glsa-200504-10.xml

    Concerns?
    =========

    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users machines is of utmost
    importance to us. Any security concerns should be addressed to
    security@gentoo.org or alternatively, you may file a bug at
    http://bugs.gentoo.org.

    License
    =======

    Copyright 2005 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).

    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.

    http://creativecommons.org/licenses/by-sa/2.0

    
    

    
    

    _______________________________________________
    Full-Disclosure - We believe in it.
    Charter: http://lists.grok.org.uk/full-disclosure-charter.html
    Hosted and sponsored by Secunia - http://secunia.com/



  • Next message: Sune Kloppenborg Jeppesen: "[Full-disclosure] [gentoo-announce] [ GLSA 200504-10 ] Gld: Remote execution of arbitrary code"

    Relevant Pages