[ GLSA 200409-26 ] Mozilla, Firefox, Thunderbird, Epiphany: New releases fix vulnerabilities

From: Thierry Carrez (koon_at_gentoo.org)
Date: 09/20/04

  • Next message: Thierry Carrez: "[Full-Disclosure] [ GLSA 200409-26 ] Mozilla, Firefox, Thunderbird, Epiphany: New releases fix vulnerabilities"
    Date: Mon, 20 Sep 2004 22:52:25 +0200
    To: gentoo-announce@lists.gentoo.org
    
    

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory GLSA 200409-26
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

      Severity: Normal
         Title: Mozilla, Firefox, Thunderbird, Epiphany: New releases fix
                vulnerabilities
          Date: September 20, 2004
          Bugs: #63996
            ID: 200409-26

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Synopsis
    ========

    New releases of Mozilla, Epiphany, Mozilla Thunderbird, and Mozilla
    Firefox fix several vulnerabilities, including the remote execution of
    arbitrary code.

    Background
    ==========

    Mozilla is a popular web browser that includes a mail and newsreader.
    Epiphany is a web browser that uses Gecko, the Mozilla rendering
    engine. Mozilla Firefox and Mozilla Thunderbird are respectively the
    next-generation browser and mail client from the Mozilla project.

    Affected packages
    =================

        -------------------------------------------------------------------
         Package / Vulnerable / Unaffected
        -------------------------------------------------------------------
      1 mozilla < 1.7.3 >= 1.7.3
      2 mozilla-firefox < 1.0_pre >= 1.0_pre
      3 mozilla-thunderbird < 0.8 >= 0.8
      4 mozilla-bin < 1.7.3 >= 1.7.3
      5 mozilla-firefox-bin < 1.0_pre >= 1.0_pre
      6 mozilla-thunderbird-bin < 0.8 >= 0.8
      7 epiphany < 1.2.9-r1 >= 1.2.9-r1
        -------------------------------------------------------------------
         7 affected packages on all of their supported architectures.
        -------------------------------------------------------------------

    Description
    ===========

    Mozilla-based products are vulnerable to multiple security issues.
    Firstly routines handling the display of BMP images and VCards contain
    an integer overflow and a stack buffer overrun. Specific pages with
    long links, when sent using the "Send Page" function, and links with
    non-ASCII hostnames could both cause heap buffer overruns.

    Several issues were found and fixed in JavaScript rights handling:
    untrusted script code could read and write to the clipboard, signed
    scripts could build confusing grant privileges dialog boxes, and when
    dragged onto trusted frames or windows, JavaScript links could access
    information and rights of the target frame or window. Finally,
    Mozilla-based mail clients (Mozilla and Mozilla Thunderbird) are
    vulnerable to a heap overflow caused by invalid POP3 mail server
    responses.

    Impact
    ======

    An attacker might be able to run arbitrary code with the rights of the
    user running the software by enticing the user to perform one of the
    following actions: view a specially-crafted BMP image or VCard, use the
    "Send Page" function on a malicious page, follow links with malicious
    hostnames, drag multiple JavaScript links in a row to another window,
    or connect to an untrusted POP3 mail server. An attacker could also use
    a malicious page with JavaScript to disclose clipboard contents or
    abuse previously-given privileges to request XPI installation
    privileges through a confusing dialog.

    Workaround
    ==========

    There is no known workaround covering all vulnerabilities.

    Resolution
    ==========

    All users should upgrade to the latest stable version:

        # emerge sync

        # emerge -pv your-version
        # emerge your-version

    References
    ==========

      [ 1 ] Mozilla Security Advisory

    http://www.mozilla.org/projects/security/known-vulnerabilities.html#mozilla1.7.3
      [ 2 ] US-CERT Security Alert TA04-261A
            http://www.us-cert.gov/cas/techalerts/TA04-261A.html

    Availability
    ============

    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:

      http://security.gentoo.org/glsa/glsa-200409-26.xml

    Concerns?
    =========

    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users machines is of utmost
    importance to us. Any security concerns should be addressed to
    security@gentoo.org or alternatively, you may file a bug at
    http://bugs.gentoo.org.

    License
    =======

    Copyright 2004 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).

    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.

    http://creativecommons.org/licenses/by-sa/1.0

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.4 (GNU/Linux)
    Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

    iD8DBQFBT0MJvcL1obalX08RAo0VAKCJut9PsDZ+w7+rmTBe4QBSsMwLDACfZ0fN
    sdTphivV2rgS3nbS4wC416Y=
    =O5VM
    -----END PGP SIGNATURE-----


  • Next message: Thierry Carrez: "[Full-Disclosure] [ GLSA 200409-26 ] Mozilla, Firefox, Thunderbird, Epiphany: New releases fix vulnerabilities"