[fw-wiz] Cisco PIX 501 Port Redirection Problem

From: Robert McIntosh (mcintoshrt_at_comcast.net)
Date: 09/03/04

  • Next message: Dave Piscitello: "Re: [fw-wiz] Linux Firewall Distributions"
    To: firewall-wizards@honor.icsalabs.com
    Date: Thu, 02 Sep 2004 22:49:01 -0700
    
    

    Hi,

    I'm trying to get my new Cisco PIX 501 to do port redirection much like
    the Linksys 4 port router did. Here's a brief topology sketch

    Internet
    |
    Modem
    |
    Cisco PIX 501
    |
    Various Clients

    One computer hosts http (europa) while the other (ganymede) hosts smtp
    traffic. I have outbound traffic, but all inbound traffic is denied,
    even though I've been explicit with port redirecting. Please review my
    config file. I'll buy the helper(s) some beer if they ever come to
    Portland, OR.

    Thanks!
    Robert

    >show config
    : Saved
    : Written by robert at 15:29:51.201 PDT Thu Sep 2 2004
    PIX Version 6.3(3)
    interface ethernet0 10full
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 6PtH3C1kB.beQFDE encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname giggles
    domain-name pacificscreening.com
    clock timezone PST -8
    clock summer-time PDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 10.0.0.7 europa
    name 10.0.0.3 ganymede
    access-list outside_access_in permit icmp any any
    access-list outside_access_in permit tcp any eq www interface outside eq www
    pager lines 24
    icmp permit any outside
    icmp permit 10.0.0.0 255.255.255.0 inside
    mtu outside 1500
    mtu inside 1500
    ip address outside dhcp setroute retry 4
    ip address inside 10.0.0.6 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 24.21.109.35 255.255.255.255 inside
    pdm location europa 255.255.255.255 inside
    pdm location ganymede 255.255.255.255 inside
    pdm location 24.21.109.35 255.255.255.255 outside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 2 interface
    global (inside) 1 interface
    nat (inside) 2 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp interface www europa www netmask
    255.255.255.255 0 0
    static (inside,outside) tcp interface ssh europa ssh netmask
    255.255.255.255 0 0
    static (inside,outside) tcp interface https europa https netmask
    255.255.255.255 0 0
    static (inside,outside) tcp interface smtp europa smtp netmask
    255.255.255.255 0 0
    static (inside,outside) tcp 24.21.109.35 995 europa 995 netmask
    255.255.255.255 0 0
    access-group outside_access_in in interface outside
    rip inside default version 2
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    aaa authentication enable console LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 10.0.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt noproxyarp outside
    sysopt noproxyarp inside
    telnet timeout 5
    ssh 10.0.0.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    dhcpd address europa-10.0.0.134 inside
    dhcpd dns 204.127.198.4
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    username robert password dmk7VFDdtqe9M.vb encrypted privilege 15
    terminal width 80
    banner motd -->Welcome to giggles.pacificscreening.com. Unauthorized
    access will be grounds for applicable litigation<--
    Cryptochecksum:5ee321577a31415530949969d9825348

    _______________________________________________
    firewall-wizards mailing list
    firewall-wizards@honor.icsalabs.com
    http://honor.icsalabs.com/mailman/listinfo/firewall-wizards


  • Next message: Dave Piscitello: "Re: [fw-wiz] Linux Firewall Distributions"

    Relevant Pages

    • Re: Static route on PIX 506e
      ... interface ethernet0 auto ... no fixup protocol dns ... access-list outside_access_in permit tcp any host 87.234.193.74 eq smtp ... pdm location 192.168.20.0 255.255.255.0 inside ...
      (comp.dcom.sys.cisco)
    • Re: PIX 501 - 2 WAN Connections, how to route certain IPs to the 2nd WAN
      ... but I need a few IPs to route over to the T-1. ... Interface named Blah with the following specs. ... fixup protocol dns maximum-length 512 ... pdm location 65.165.202.144 255.255.255.248 outside ...
      (comp.dcom.sys.cisco)
    • PIX 501 - 2 WAN Connections, how to route certain IPs to the 2nd WAN
      ... 1=Broadband connection with static IP ... Interface named Blah with the following specs. ... fixup protocol dns maximum-length 512 ... pdm location 65.165.202.144 255.255.255.248 outside ...
      (comp.dcom.sys.cisco)
    • Re: Setup Remote VPN on PIX 501
      ... interface ethernet1 100full ... fixup protocol dns maximum-length 512 ... pdm location 12.151.16.35 255.255.255.255 outside ... access-group outside_access_in in interface outside ...
      (comp.dcom.sys.cisco)
    • Re: Pix Configuration (PPPoe, VPN, between 3 sites)
      ... > interface ethernet0 auto ... > fixup protocol dns maximum-length 512 ... > timeout xlate 0:05:00 ... > isakmp policy 20 authentication pre-share ...
      (comp.dcom.sys.cisco)