[fw-wiz] full IPSEC tunnels on PIX and NAT ...

From: peter bartoli (peter_at_alphafight.net)
Date: 11/29/03

  • Next message: Joe Cupano: "[fw-wiz] RE: Dynamic routing on a firewall"
    To: firewall-wizards@honor.icsalabs.com
    Date: Sat, 29 Nov 2003 12:39:55 -0800
    
    

    ... hello, and thank you in advance for any help you might be able to
    offer.

    I've got a PIX that I'm using for just a couple of clients to VPN into,
    and would really like to get full tunnels working so that all their
    traffic goes over the tunnel and then out to the internet.

    I've scoured all of Cisco's documentation, and can't find anything I'm
    doing wrong, but I seem to be stuck with the following kind of error
    message:

    Nov 27 15:58:22 guardian.slagheap.net %PIX-3-106011: Deny inbound (No
    xlate) tcp src outside:192.168.253.1/49315 dst
    outside:198.133.219.25/80

    I've tried all manner of nat statements to try to get this to work, but
    with no avail. Please find my config below; I really appreciate any
    help.

    -peter

    PIX Version 6.3(1)
    interface ethernet0 auto
    interface ethernet1 auto
    interface ethernet2 auto
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    nameif ethernet2 dmz security25
    enable password ******** encrypted
    passwd ******** encrypted
    hostname ********
    domain-name ********
    clock timezone PST -8
    clock summer-time PDT recurring
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol ils 389
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    names
    access-list 101 permit ip 192.168.0.0 255.255.0.0 192.168.253.0
    255.255.255.0
    pager lines 24
    logging on
    logging buffered notifications
    logging trap warnings
    logging facility 23
    logging host dmz 192.168.0.2
    mtu outside 1500
    mtu inside 1500
    mtu dmz 1500
    ip address outside ******** 255.255.255.0
    ip address inside 192.168.1.2 255.255.255.0
    ip address dmz 192.168.0.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool vpnpool 192.168.253.1-192.168.253.254
    no failover
    failover timeout 0:00:00
    failover poll 15
    no failover ip address outside
    no failover ip address inside
    no failover ip address dmz
    pdm history enable
    arp timeout 60
    global (outside) 1 interface
    nat (inside) 0 access-list 101
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    nat (dmz) 0 access-list 101
    nat (dmz) 1 192.168.0.0 255.255.255.0 0 0
    static (inside,dmz) 192.168.1.0 192.168.1.0 netmask 255.255.255.0 0 0
    static (inside,dmz) 192.168.2.0 192.168.2.0 netmask 255.255.255.0 0 0
    static (inside,dmz) 192.168.254.0 192.168.254.0 netmask 255.255.255.0 0
    0
    static (dmz,inside) 192.168.0.2 192.168.0.2 netmask 255.255.255.255 0 0
    static (dmz,outside) ******** 192.168.0.2 netmask 255.255.255.255 0 0
    conduit permit tcp host ******** eq smtp any
    conduit permit tcp host ******** eq www any
    conduit permit tcp host 192.168.1.9 eq lpd host 192.168.0.2
    conduit permit icmp ******** 255.255.255.0 any echo-reply
    conduit permit icmp ******** 255.255.255.0 any source-quench
    conduit permit icmp ******** 255.255.255.0 any unreachable
    conduit permit icmp ******** 255.255.255.0 any time-exceeded
    route outside 0.0.0.0 0.0.0.0 ******** 1
    route inside 192.168.2.0 255.255.255.0 192.168.1.1 1
    route inside 192.168.254.0 255.255.255.0 192.168.1.1 1
    timeout xlate 96:00:00
    timeout conn 0:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set vpnset esp-3des esp-sha-hmac
    crypto dynamic-map vpnmap 10 set transform-set vpnset
    crypto map ******** 10 ipsec-isakmp dynamic vpnmap
    crypto map ******** interface outside
    isakmp enable outside
    isakmp identity address
    isakmp policy 10 authentication pre-share
    isakmp policy 10 encryption 3des
    isakmp policy 10 hash sha
    isakmp policy 10 group 2
    isakmp policy 10 lifetime 86400
    vpngroup ******** address-pool vpnpool
    vpngroup ******** dns-server 192.168.0.2
    vpngroup ******** default-domain ********
    vpngroup ******** split-tunnel 101
    vpngroup ******** idle-time 7200
    vpngroup ******** password ********
    vpngroup wireful address-pool vpnpool
    vpngroup wireful dns-server 192.168.0.2
    vpngroup wireful default-domain ********
    vpngroup wireful idle-time 7200
    vpngroup wireful password ********
    vpngroup dns-server idle-time 1800
    telnet timeout 5
    ssh timeout 15
    console timeout 0
    terminal width 80
    Cryptochecksum: ********
    : end

    _______________________________________________
    firewall-wizards mailing list
    firewall-wizards@honor.icsalabs.com
    http://honor.icsalabs.com/mailman/listinfo/firewall-wizards


  • Next message: Joe Cupano: "[fw-wiz] RE: Dynamic routing on a firewall"

    Relevant Pages

    • Re: Please help with Pix 501
      ... fixup protocol h323 ras 1718-1719 ... timeout xlate 0:05:00 ... --> isakmp policy 7 hash sha ... dhcpd address 192.168.69.100-192.168.69.120 inside ...
      (comp.dcom.sys.cisco)
    • Re: Please help with Pix 501
      ... fixup protocol h323 ras 1718-1719 ... timeout xlate 0:05:00 ... --> isakmp policy 7 hash sha ... dhcpd address 192.168.69.100-192.168.69.120 inside ...
      (comp.dcom.sys.cisco)
    • Re: Problems configuring my PIX525
      ... > 3) Outside interface will be assigned 1 IP address and all outgoing ... > fixup protocol http 80 ... > failover timeout 0:00:00 ...
      (comp.security.firewalls)
    • VPN problem followup, trying to connect PIX and Router
      ... crypto map To_PIX 25 ipsec-isakmp ... fixup protocol dns maximum-length 512 ... timeout xlate 3:00:00 ... isakmp policy 10 authentication pre-share ...
      (comp.dcom.sys.cisco)
    • Re: PIX 704 Connat pass traffix
      ... Unless you know PIX OS inside and out you should refrain ... > timeout xlate 3:00:00 ... > dhcpd address 10.5.1.50-10.5.1.60 inside ... > fixup protocol dns maximum-length 512 ...
      (comp.dcom.sys.cisco)