US-CERT Technical Cyber Security Alert TA06-333A -- Apple Releases Security Update to Address Multiple Vulnerabilities

Hash: SHA1

National Cyber Alert System

Technical Cyber Security Alert TA06-333A

Apple Releases Security Update to Address Multiple Vulnerabilities

Original release date: November 29, 2006
Last revised: --
Source: US-CERT

Systems Affected

* Apple Mac OS X version 10.3.x and 10.4.x
* Apple Mac OS X Server version 10.3.x and 10.4.x
* Apple Safari web browser

These vulnerabilities affect both Intel-based and PowerPC-based Apple


Apple has released Security Update 2006-007 to correct multiple
vulnerabilities affecting Mac OS X, Mac OS X Server, Safari web
browser. Vulnerabilities in OpenSSL, gzip, and other products are also
addressed. The most serious of these vulnerabilities may allow a
remote attacker to execute arbitrary code. Attackers may take
advantage of the less serious vulnerabilities to bypass security
restrictions or cause a denial of service.

I. Description

Apple Security Update 2006-007 addresses a number of vulnerabilities
affecting Mac OS X, OS X Server, Safari web browser, and other
products. Further details are available in the related vulnerability

This security update also addresses previously known vulnerabilities
in PHP, Perl, OpenSSL, and gzip, which are shipped with Mac OS X. The
OpenSSL vulnerabilities are documented in multiple vulnerability
notes. Information is also available through the OpenSSL
vulnerabilities page. Information about the vulnerabilities in gzip is
available in a series of vulnerability notes.

II. Impact

The impacts of these vulnerabilities vary. For specific details, see
the appropriate vulnerability notes. Potential consequences include
remote execution of arbitrary code or commands, bypass of security
restrictions, and denial of service.

III. Solution

Install updates

Install Apple Security Update 2006-007. This and other updates are
available via Apple Update or via Apple Downloads.

IV. References

* Vulnerability Notes for Apple Security Update 2006-007 -

* Vulnerability Notes for OpenSSL Security Advisory [28th September
2006] -

* Vulnerability Note VU#845620 -

* Vulnerability Note VU#933712 -

* Vulnerability Note VU#381508 -

* Vulnerability Note VU#554780 -

* Vulnerability Note VU#596848 -

* Vulnerability Note VU#773548 -

* About the security content of Security Update 2006-007 -

* Mac OS X: Updating your software -

* Apple Downloads - <>

* OpenSSL: OpenSSL vulnerabilities -

* Securing Your Web Browser -


The most recent version of this document can be found at:


Feedback can be directed to US-CERT Technical Staff. Please send
email to <cert@xxxxxxxx> with "TA06-333A Feedback VU#191336" in the

Produced 2006 by US-CERT, a government organization.

Terms of use:



Revision History

November 29, 2006: Initial release

Version: GnuPG v1.2.1 (GNU/Linux)


Relevant Pages